Linux HOWTOs

About | Home | Search


HOWTO: abiword
Description: A wordprocessor for X, similar to M$ Word
Click here for ChangeLog
NOTE: I use GNU tar >= 1.13.25 so it's -j for .tar.bz2 files,
it's safe to assume that make, gcc, binutils, fileutils/coreutils, gawk, sed, and grep are prerequisites for almost everything


# AbiWord
# =======
# Slackware 9.0's 'abiword' package includes version 1.0.6, 9.1's includes
# 2.0.0, 10.0's includes 2.0.6, 10.1 includes 2.0.12, and 10.2 includes
# 2.2.9

# Because of the different prerequisites that are required of each, I
# include the 2.0.x, 2.2.x, and 2.4.x branches here, though keep in mind
# that I only use the 2.4.x version myself.

# As of version 2.0.2, abiword and abiword-plugins come together in the same
# tarball.  If you're upgrading a two tarball version, do this before you
# get started below:
cd
test -d installed/abiword &&
 ( rm -f installed/abiword/abiword-plugins-*
   mv -f installed/abiword/* installed/
   rmdir installed/abiword )
test -d ~/src/abiword &&
 ( find ~/src/abiword -mindepth 1 -maxdepth 1 -type d \
    -name "abiword-plugins-*" -exec rm -r {} \;
   mv ~/src/abiword/* ~/src/
   rmdir ~/src/abiword )


# abiword 2.0.14
# ==============
# Prerequisites:
# gawk
# pkg-config
# glib >= 2.0
# gtk+ >= 2.0
# XFree86 or X.org
# libiconv
# gucharmap (optional) >= 0.7 and < 1.3.0
# Xft2, FontConfig (optional; these are part of X)
# For spelling: enchant or aspell/pspell >= 0.12.0 (optional; I'd go
#   with enchant)
# fribidi >= 0.10.4
# expat and/or libxml2
# wv (optional - they include a version in ./wv/, if you want
#   to use the system one, pass --with-sys-wv to configure )
# zlib
# libpng
# popt
# libjpeg (optional)
# imagemagick (optional)
# perl (optional; if you pass --enable-scripting)
# If you pass --enable-gnome to configure below, you also need these:
# libglade >= 2.0.0
# libbonobo >= 2.0
# libgnomeui >= 2.0
# libgnomeprint >= 2.2.1
# libgnomeprintui >= 2.2.1
# libnautilus >= 2.0

cd
test -f installed/abiword-2.0.14.tar.bz2 &&
 mv installed/abiword-2.0.14.tar.bz2 .
test ! -f abiword-2.0.14.tar.bz2 &&
 wget http://download.sf.net/abiword/abiword-2.0.14.tar.bz2

# Verify tarball w/ md5sum:
# (this came from my copy, this will only verify that yours is identical to
# mine; I couldn't find one anywhere on their site or in the announcement)
echo "3fb61de6c57406d8d3cd68d65562e3ad  abiword-2.0.14.tar.bz2" | md5sum -c

mkdir -p -m 0700 src
cd src
find -maxdepth 1 -type d -name "abiword-*" -exec rm -r {} \;
tar xjvf ~/abiword-2.0.14.tar.bz2
cd abiword-2.0.14
test $UID = 0 && chown -R root:root .
cd abi

# I was unable to get it to build with --enable-gnome under Slackware 9.0
# which comes with Gnome 2.2.x (even after upgrading a few things like
# gnome-vfs).  If you use Gnome 2.2.x, you may need to remove --enable-gnome
# from the configure line below.  [ Slack 9.1 comes with Gnome 2.4.x, Slack
# 10.0 comes with Gnome 2.6.x, I haven't had any trouble with them ]

# The --enable-scripting option builds in perl scripting support, but as of
# the last time I checked this hadn't been updated to work with anything newer
# than perl 5.8.0 (5.8.5 is current), so I leave it off below.

./configure \
 --prefix=/usr \
 --enable-threads \
 --disable-pspell \
 --enable-extra-optimization \
 --with-ImageMagick \
 --with-libxml2 \
 --with-zlib \
 --with-libpng \
 --with-popt \
 --enable-gnome
make

# Become root to install it
su

test -x /sbin/removepkg && /sbin/removepkg abiword
make install

# Become yourself again
exit

cd
mkdir -p -m 0700 installed
rm -f installed/abiword-*.tar.*
mv abiword-2.0.14.tar.bz2 installed/

# /usr/share/icons/abiword_48.png can be used as a desktop icon


# abiword-plugins
# ===============
# These (AFAIK) are all optional prerequisites (in addition to everything
# listed above).  If you leave any out, the appropriate plugins won't build.
# readline
# aiksaurus >= 1.0
# libgda and libgnomedb >= 0.90.0
# python 2.3.x (see note below)
# gdk-pixbuf
# librsvg >= 2.0
# imagemagick >= 5.4.0
# libwmf >= 0.2.8
# bzip2
# libgsf >= 1.4.0
# libwpd >= 0.5.0
# libxml >= 2.0
# libots
# EPS
# psiconv 0.8.3

# If you had to remove --enable-gnome for abiword itself, remove it here
# for the plugins too

# The gypsython plugin has been updated as of abiword 2.0.5 to work with
# python 2.3  It requires that python was installed with --enable-shared (a
# shared libpython library).  My python howto, as of the last update, builds
# python with the shared library.

# If you have psiconv 0.9.4 installed, add --disable-psion below.  I tried it,
# that plugin won't build with that version, but it builds with version 0.8.3

cd ~/src/abiword-2.0.14/abiword-plugins
./configure --prefix=/usr --enable-gnome
make
su -c "make install"

# ============================================================================

# abiword 2.2.11
# ==============
# Prerequisites:
# gawk
# grep
# pkg-config
# glib >= 2.0
# gtk+ >= 2.2.0
# XFree86 or X.org
# libiconv
# gucharmap >= 1.4 (optional)
# Xft2, FontConfig (optional; these are part of X)
# For spelling: enchant >= 1.1.0 or aspell/pspell >= 0.12.0 (optional; I'd
#   go with enchant)
# fribidi >= 0.10.4
# perl (optional; if you pass --enable-scripting)
# expat and/or libxml2
# wv (optional - they include a version in ./wv/, if you want
#   to use the system one, pass --with-sys-wv to configure )
# zlib
# libpng
# popt
# libjpeg (optional)
# imagemagick (optional)
# If you pass --enable-gnome to configure below, you also need these:
# libglade >= 2.0.0
# libbonobo >= 2.0
# libgnomeui >= 2.0
# libgnomeprint >= 2.2.1
# libgnomeprintui >= 2.2.1
# libnautilus >= 2.0

cd
test -f installed/abiword-2.2.11.tar.bz2 &&
 mv installed/abiword-2.2.11.tar.bz2 .
test ! -f abiword-2.2.11.tar.bz2 &&
 wget http://www.abisource.com/downloads/abiword/2.2.11/source/\
abiword-2.2.11.tar.bz2

# Verify tarball w/ md5sum:
echo "bbeb471f1232560327757b2574b4fb3b  abiword-2.2.11.tar.bz2" | md5sum -c

mkdir -p -m 0700 src
cd src
find -maxdepth 1 -type d -name "abiword-*" -exec rm -r {} \;
tar xjvf ~/abiword-2.2.11.tar.bz2
cd abiword-2.2.11
test $UID = 0 && chown -R root:root .
cd abi

# I was unable to get it to build with --enable-gnome under Slackware 9.0
# which comes with Gnome 2.2.x (even after upgrading a few things like
# gnome-vfs).  If you use Gnome 2.2.x, you may need to remove --enable-gnome
# from the configure line below.  Slack 9.1 comes with Gnome 2.4.x, Slack
# 10.0 and 10.1 come with Gnome 2.6.x, I haven't had any trouble with them.

# Previous versions couldn't build with --enable-scripting (perl) support
# with any version of perl more recent than 5.8.0, but it did work for me
# with Abiword 2.2.3 with perl 5.8.5 and Abiword 2.2.5/2.2.7 with perl 5.8.6

./configure \
 --prefix=/usr \
 --enable-threads \
 --disable-pspell \
 --enable-extra-optimization \
 --with-ImageMagick \
 --with-libxml2 \
 --with-zlib \
 --with-libpng \
 --with-popt \
 --enable-gnome \
 --enable-scripting
make

# Become root to clean up old files and to install it
su

test -x /sbin/removepkg && /sbin/removepkg abiword

# If you're upgrading from a previous minor version (ie. 2.0.x to 2.2.x), run
# this to zap the old version's files:
rm -f /usr/bin/AbiWord-*
find /usr/share -maxdepth 1 -type d -name "AbiSuite-*" -exec rm -r {} \;

make install
chown -R $USER .

# Become yourself again
exit

cd
mkdir -p -m 0700 installed
rm -f installed/abiword-*.tar.*
mv abiword-2.2.11.tar.bz2 installed/

# /usr/share/icons/abiword_48.png can be used as a desktop icon


# abiword-plugins
# ===============
# These (AFAIK) are all optional prerequisites (in addition to everything
# listed above).  If you leave any out, the appropriate plugins won't build.
# readline
# aiksaurus >= 1.0
# libgda and libgnomedb >= 0.90.0
# python 2.3.x (see note below)
# libots-1 >= 0.4.1
# gdk-pixbuf
# librsvg >= 2.0
# imagemagick >= 5.5.0
# libwmf >= 0.2.8
# bzip2
# libgsf >= 1.4.0
# libwpd >= 0.7.0
# libxml >= 2.4.20
# psiconv >= 0.9.1

# If you had to remove --enable-gnome for abiword itself, remove it here
# for the plugins too

# The gypsython plugin has been updated as of abiword 2.0.5 to work with
# python 2.3  It requires that python was installed with --enable-shared (a
# shared libpython library).  My python howto, as of the last update, builds
# python with the shared library.  Unfortunately, python 2.4 is out now and
# it hasn't yet been updated to work with it.

cd ~/src/abiword-2.2.11/abiword-plugins
./configure --prefix=/usr --enable-gnome
make
su -c "make install"

# ============================================================================

# abiword 2.4.5
# ==============
# Prerequisites:
# gawk
# grep
# pkg-config
# glib >= 2.0
# gtk+ >= 2.4.0
# pango >= 1.2.0
# libglade >= 2.0.0
# XFree86 or X.org
# libgnomeprint >= 2.2.0
# libgnomeprintui >= 2.2.0
# iconv
# gucharmap >= 1.4 (optional)
# For spelling: enchant >= 1.1.0 or aspell/pspell >= 0.12.0 (optional; I'd
#   go with enchant)
# fribidi >= 0.10.4
# perl (optional; for --enable-scripting)
# expat and/or libxml2
# wv (optional - they include a version in ./wv/, if you want
#   to use the system one, pass --with-sys-wv to configure )
# zlib
# libpng
# popt
# libjpeg (optional)
# imagemagick (optional; for --with-ImageMagick)
# If you pass --enable-gnome to configure below, you also need these:
# libbonobo >= 2.0
# libgnomeui >= 2.0

cd
test -f installed/abiword-2.4.5.tar.bz2 &&
 mv installed/abiword-2.4.5.tar.bz2 .
test ! -f abiword-2.4.5.tar.bz2 &&
 wget http://www.abisource.com/downloads/abiword/2.4.5/source/\
abiword-2.4.5.tar.bz2

# Verify tarball w/ md5sum:
echo "e018669a154164d31c768f773a1c95b4  abiword-2.4.5.tar.bz2" | md5sum -c

mkdir -p -m 0700 src
cd src
find -maxdepth 1 -type d -name "abiword-*" -exec rm -r {} \;
tar xjvf ~/abiword-2.4.5.tar.bz2
cd abiword-2.4.5
test $UID = 0 && chown -R root:root .
cd abi

# I was unable to build it with --enable-scripting (perl) last time with
# 2.4.2, but it was OK this time with 2.4.5  I think it was perl 5.8.8
# both times, but I'm not positive.

./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
 --enable-threads --enable-extra-optimization --enable-gnome \
 --with-ImageMagick
make

# Become root to clean up old files and to install it
su

test -x /sbin/removepkg && /sbin/removepkg abiword

# If you're upgrading from a previous minor version (ie. 2.2.x to 2.4.x),
# run this to zap the old version's files:
rm -f /usr/bin/AbiWord-*
find /usr/share -maxdepth 1 -type d -name "AbiSuite-*" -exec rm -r {} \;

make install
chown -R $USER .

# Become yourself again
exit

cd
mkdir -p -m 0700 installed
rm -f installed/abiword-*.tar.*
mv abiword-2.4.5.tar.bz2 installed/

# /usr/share/icons/abiword_48.png can be used as a desktop icon


# abiword-plugins
# ===============
# These (AFAIK) are all optional prerequisites (in addition to everything
# listed above).  If you leave any out, the appropriate plugins won't build.
# libnautilus >= 2.0
# readline
# libgoffice-1 >= 0.1.0
# link-grammar >= 4.1.1 (below)
# mathview-frontend-libxml2 >= 0.7.5 (below)
# aiksaurus >= 1.0
# libgda and libgnomedb >= 1.2.0
# libots-1 >= 0.4.1
# librsvg >= 2.0
# libwmf >= 0.2.8
# bzip2
# libgsf-1 >= 1.11.1
# poppler >= 0.4.0
# psiconv >= 0.9.1
# libwpd >= 0.8.0
# libxml >= 2.4.20
# eps (1.2 is OK, but not 1.5)


# link-grammar 4.2.3
# ==================
cd
test -f installed/link-grammar-4.2.3.tar.gz &&
 mv installed/link-grammar-4.2.3.tar.gz .
test ! -f link-grammar-4.2.3.tar.gz &&
 wget http://www.abisource.com/downloads/link-grammar/4.2.3/\
link-grammar-4.2.3.tar.gz
mkdir -p -m 0700 src
cd src
find -maxdepth 1 -type d -name "link-grammar-*" -exec rm -r {} \;
tar xzvf ~/link-grammar-4.2.3.tar.gz
cd link-grammar-4.2.3
test $UID = 0 && chown -R root:root .
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var/lib
make

# Become root to install it
su

rm -f /usr/lib/liblink-grammar.*
make install
ldconfig

# Become yourself again
exit

cd
mkdir -p -m 0700 installed
rm -f installed/link-grammar-*.tar.*
mv link-grammar-4.2.3.tar.gz installed/


# libmathview 0.7.6
# =================
# I skip this one due to build errors when I tried it

cd
test -f installed/libmathview-0.7.6-dev.zip &&
 mv installed/libmathview-0.7.6-dev.zip .
test ! -f libmathview-0.7.6-dev.zip &&
 wget http://www.abisource.com/downloads/dependencies/gtkmathview/\
libmathview-0.7.6-dev.zip

# Become root to install it
su

# Remove an old installed version
test -d /usr/include/gtkmathview && rm -r /usr/include/gtkmathview
rm -f /usr/include/MathView \
 /usr/lib/pkgconfig/mathview-core.pc \
 /usr/lib/pkgconfig/mathview-frontend-libxml2.pc \
 /usr/lib/libmathview.* \
 /usr/lib/libmathview_frontend_libxml2.* \
 /usr/man/man1/mathmlviewer.1

# Install (unzip) the new version
unzip -d /usr libmathview-0.7.6-dev.zip
ln -s /usr/include/gtkmathview/MathView /usr/include/MathView

# Become yourself again
exit

cd
mkdir -p -m 0700 installed
rm -f installed/libmathview-*.zip
mv libmathview-0.7.6-dev.zip installed/


# eps 1.5 doesn't seem to work with AbiWord 2.4.2, I didn't try it this
# time with 2.4.5.  If you have 1.5 installed, pass --without-inter7eps
# to configure to skip it.  Building with eps 1.2 seems to be OK.

cd ~/src/abiword-2.4.5/abiword-plugins
./configure --prefix=/usr --enable-gnome --without-abimathview \
 --without-inter7eps

## No longer necessary?
# If you installed libmathview:
( cd tools/abimathview/itex2MML ; make -f Makefile.itex2MML )

make
su -c "make install"

Back to the list


Last updated: Tue, 07 Aug 2018 12:06:17 -0400
Jason Englander <jason at englanders dot us>