Linux HOWTOs

About | Home | Search


HOWTO: popt
Description: Commandline parsing library
Click here for ChangeLog
NOTE: I use GNU tar >= 1.13.25 so it's -j for .tar.bz2 files,
it's safe to assume that make, gcc, binutils, fileutils/coreutils, gawk, sed, and grep are prerequisites for almost everything


# popt 1.7
# ========
# Slackware 9.0, 9.1, 10.0, 10.1, and 10.2's 'popt' packages include version
# 1.7

# Prerequisites:
# gawk
# gettext
# libiconv
# bison

cd
test -f installed/popt-1.7.tar.gz && mv installed/popt-1.7.tar.gz .
test ! -f popt-1.7.tar.gz &&
 wget ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.1.x/popt-1.7.tar.gz
mkdir -p -m 0700 src
cd src
find -maxdepth 1 -type d -name "popt-*" -exec rm -r {} \;
tar xzvf ~/popt-1.7.tar.gz
cd popt-1.7
test $UID = 0 && chown -R root:root .
./configure --prefix=/usr --sysconfdir=/etc --disable-nls
make

# Become root to install it
su

removepkg popt
rm -f /usr/lib/libpopt.*
make install
ldconfig

## Now open up the /var/adm/packages/*elflibs* file in a text editor and
## remove the line that looks like this:
# usr/lib/libpopt.so.0.0.0

# Become yourself again
exit

cd
mkdir -p -m 0700 installed
rm -f installed/popt-*.tar.*
mv popt-1.7.tar.gz installed/

Back to the list


Last updated: Wed, 29 Apr 2020 22:04:50 -0400
Jason Englander <jason at englanders dot us>